Навчальні статті. Урок - Цикли в BAS

Зміст
  1. Цикли в BAS.
  2. Вид циклу "Пока"
  3. Лістинг 1. Простий цикл Пока
  4. Лістинг 2. Простий цикл Пока Прервать
  5. Лістинг 3. Простий цикл Пока Продолжить
  6. Вид циклу "Для каждого из"
  7. Лістинг 4. Простий цикл Для каждого
  8. Вип циклу "Для По"
  9. Лістинг 5. Простий цикл Для По

Зустрічаємо новий трудовий тиждень черговим випуском навчального уроку.

Сьогодні ми розглянемо, що собою представляють

Цикли в BAS.

Цикли використовуються для повторення деякого числа рядків програмного коду або для перебору, наприклад, таблиці значень, списку значень або масиву.

Цикли бувають декількох видів.

Вид циклу "Пока"

Пока<Какое-то условие>Цикл

//Ваш код, що виконується

КонецЦикла;

Це найпростіша конструкція. Умовою може бути або рівність, яке значення булево і т.д.

Наприклад:

Запишемо змінну перед початком циклу «Перем1» - вона у нас буде виступати в ролі обмежувача циклу.

Потім вкажемо в циклі умова «Перем1 <> 5», тобто цикл буде виконуватися поки наша змінна не прийме значення число п'ять.

Після цього (вже в циклі), повідомимо значення нашої змінної і збільшимо значення змінної на плюс один, переписуючи змінну.

Лістинг 1. Простий цикл Пока

Листинг кода 1. Пример Цикла

 

У циклів є кілька основних операторів.

Прервать - перериває повністю цикл. У зазначеному рядку.

Лістинг 2. Простий цикл Пока Прервать

Листинг кода 2. Пример Цикла с условием

Продолжить – після потрапляння на цю сходинку, платформа повернеться в початок циклу. А все що після цього рядка не буде виконано.

Лістинг 3. Простий цикл Пока Продолжить

Листинг кода 3. Пример Цикла с условием Продолжить

 

Вид циклу "Для каждого из"

Для каждого<имя переменной>ИЗ<Имя объекта для перебора>Цикл

//Ваш исполняемый код

КонецЦикла;

Такий цикл добре підходить для перебору рядків таблиці значень і інших універсальних колекцій, таких як масив або список значень. Давайте зробимо приклад. Створимо таблицю значень, заповнимо її кількома рядками і колонками і повідомимо результат.

Лістинг 4. Простий цикл Для каждого

Листинг кода 4. Пример Цикла с условием перебора ТЗ

При такому циклі, змінна «Стр» записала в себе значення «СтрокаТаблицыЗначений». У цієї змінної, через точку, можна звернутися до колонок і їх значень.

Вип циклу "Для По"

Схожий на попередній цикл. Має таку конструкцію:

Для <имя переменной> = <Выражение 1>ПО<Выражение 2>Цикл

//Ваш исполняемый код

КонецЦикла;

Такий цикл менш поширений і слугує для виконання циклу по певній кількості підходів, зазначених у <Выражение 2>. Зробимо приклад.

Лістинг 5. Простий цикл Для По

Листинг кода 5. Пример Цикла с условием ПО

Нюанс цього циклу полягає в змінної «Перем1», яку ми визначаємо і задаємо їй значення в першій частині конструкції циклу. «Перем1» на початку циклу дорівнює одиниці, але з кожною итерацией (проходження повного циклу) ця змінна буде рости на плюс один автоматично. Якщо повернуться, наприклад циклу «Пока», то там ми самостійно записували змінну, тут же цикл робить це автоматично.

Больш детально з циклами можна ознайомитися на наших курсах програмування BAS и онлайн програмування BAS

Також, наша компанія проводить навчання за курсами:

Навчання проводиться у вечірній час, що дозволить вам не відриватися від роботи або навчання, практикуючим програмістом нашої компанії.

Якщо у вас залишилися питання, Ви завжди можете звернутися до наших аналітиків за телефонами:
(093) 090-70-20
(095) 090-70-20
(068) 090-70-20

( 22 )
Коментарі
Поки немає відгуків
Написати коментар

Зв'яжіться з нами

Якщо ви хочете отримати більше інформації, заповніть цю форму. Ми зв'яжемося з вами найближчим часом.

(095) 090-70-20 (068) 090-70-20 (093) 090-70-20 info@finsoft.ua